New Members: Be sure to confirm your email address by clicking on the link that was sent to your email inbox. You will not be able to post messages until you click that link.

scanning syntax errors inconsistent

I am developing a new scan and have 2 kinds of problems. Here is the basic scan:

[type is stock] and [sma(20,volume) > 100000]
//and [SCTR >yesterdays SCTR * 1.075]
rank by [PctChange(10, SCTR)]
//and [SCTR >yesterdays SCTR * 1.075]
#past 10 days ranked
//and [SCTR >yesterdays SCTR * 1.075]

Of the six lines, I can activate line 2 and get a correct message on the syntax. (Activate means erasing the //)
Lines 4 and 6 are copies (copy and paste) of line 2. When I activate either line 4 or 6, I get a syntax error. (Only 1 line of 2,4,6 is activated at a time)
Any ideas what's wrong? I've tried restarting Windows 10 several times. I've tried running this on a MAC. Same result.

The second issue is that when I run a scan in development, it's ok initially. When I add a new line to the existing 10 lines, all of a sudden it will not recognize the new line and scans for the previous criteria only.
Any ideas here?

Thanks for any suggestions.

Best Answer

Sign In or Register to comment.