New Members: Be sure to confirm your email address by clicking on the link that was sent to your email inbox. You will not be able to post messages until you click that link.

Can't explain. Is this a bug of the scanner or I don't understand how the scanner work.


I would expect the two scans below return the same number of results. The condition [ SMA(20,SCTR) >= 0 ] should be always true. ?

Would appreciate anyone can shed some light.

Thnx

1st scan returned 158 results -----

type is Stock ] and [ group is ETF ] and [ country is US ]

and [SCTR > 60] and [SCTR < 70 ]


2nd scan returned 138 results ----

type is Stock ] and [ group is ETF ] and [ country is US ]

and [SCTR > 60] and [SCTR < 70 ]
and [ SMA(20,SCTR) >= 0 ]

Answers

  • markdmarkd mod
    edited April 12
    It would not be true if there were not twenty data points to calculate the SCTR's sma.

    You could verify whether this is the case by putting the larger results into a list and adding the SCTR indicator to your chart style.
  • lmkwinlmkwin ✭✭
    edited April 12
    a good way to see things is to use the Rank By statement. If you use this on the 1st scan code, you can see the ones that will be excluded by the 2nd code set.

    rank by [SMA(20,SCTR)]

    could be a bug
  • markdmarkd mod
    edited April 12
    Well, some interesting results -

    if you run the scan with "rank by" as @lmkwin suggests - the results page shows about 20 symbols with no SCTR value. But, if you put the results into a list and add SCTR Line to the chart with an sma 20 overlay, it shows a SCTR line for every symbol and an MA.

    So, that suggests the scan engine database and the charting database are using different data, or different criteria for SCTR groupings.

    The technically correct terminology for etf SCTRs is sctr.us.etf, but even if you edit the scan for this refinement, the results are the same.

    So, it seems either the scan engine sctr calculation procedure has not been told these symbols belong in the etf sctr calculation (some table has not been updated), or the chart engine sctr indicator has not been told to exclude them.

    Support should probably be told.
  • It helps. Reported the problem to support. Thnx.
  • lmkwinlmkwin ✭✭
    Another option for checking is to just click on the SharpChart link on the results, and create a chartstyle with the appropriate settings, and then just Save as Default style. It doesn't need to have a name. You are using it for checking the charts. This avoids creating a list that you have to delete if not needed. You can go back and forth with the results, clicking on the SharpChart link in the result and the new chart will open with your "test" criteria you saved as default.
  • edited April 28
    This is definitely a scanner error.
    Please visit my site

    Edit Admin: link to site removed as links to third party promotional sites are not allowed.
  • lmkwinlmkwin ✭✭
    SPAM post!!
Sign In or Register to comment.